Заказ звонка

Закрыть

*
*
*

Не работает группировка

Страницы: 1
RSS
Не работает группировка
Здравствуйте! Отчет из набора данных документы! Нужно сгруппировать по материалу и его компонентам! Области настроил, поля указал, но он категорически отказывается группировать! Все уже перепробовал, ничего не помогает! Подскажите, где я не так что делаю! Делаю все как в хелпе!
Файл приложил!
Изменено: Дмитрий Алексеев - 02.04.2012 11:34:52
Еще сразу вопрос. Как можно определить условие формирования строк с совпадающими значениями? В наборе данных Данные в аксесс это были 4,5,6 служебные поля, а как здесь? Что то не найду!
Второе условие группировки заданно не совсем верно. Посмотрите в документации, там есть примеры: http://www.tcsdev.com/support/reporter_guide/index.html?3_4_6.htm
Цитата
Андрей Бусел пишет:
Второе условие группировки заданно не совсем верно. Посмотрите в документации, там есть примеры: http://www.tcsdev.com/support/reporter_guide/index.html?3_4_6.htm


Я это видел! Не понятно написано!
<< ИЛИ(%-$0% <> %$0%; %-$1% <> %$1%) >> вот это как я понимаю(как там написано) четыре разных поля, ну если не 0 и 1, а допустим 4 и 8!
т.к. -$0 - значение поля из предыдущей записи основного источника данных
$0 - значение поля из текущей записи основного источника данных
И это очень путает!

Я два дня убил, все варианты испробовал!
Вот мне надо по 5 и 9 полю (допустим) сгруппировать!
Как это мне написать правильно?
Или может есть какие нибудь бланки с группировкой готовые?! Для примера!
Изменено: Дмитрий Алексеев - 03.04.2012 09:02:13
А вы сами вообще проверяли работу группировки, где группируется более чем по одному полю? Может она и не работает вовсе?! А я тут бьюсь!
Страницы: 1
Читают тему (гостей: 1, пользователей: 0, из них скрытых: 0)